Quiesced Snapshot of a Proxmox VE VM Cannot Be Created

Product version: 11.0

Last modified: 11 September 2024

Problem

The following error message appears:

Quiesced (application-aware) snapshot of this VM cannot be created.

Background

When the application-aware mode is enabled, NAKIVO Backup & Replication uses QEMU Guest Agent quiescing to ensure the application data is consistent. QEMU Guest Agent quiescing uses Volume Shadow Copy Service (VSS) to freeze I/O requests of applications inside the OS.

If QEMU Guest Agent quiescing fails to create an application-consistent snapshot, NAKIVO Backup & Replication displays the above error.

Possible Causes

The error may be caused by:

  1. QEMU Guest Agent is not installed on the source VM.

  2. QEMU Guest Agent is not running on the source VM.

  3. QEMU Guest Agent on the source VM is out-of-date.

  4. Volume Shadow Copy Service (VSS) is not running properly on the source VM.

Solutions

  1. QEMU Guest Agent is not installed on the source VM: Update your virtual infrastructure (in particular the hypervisor on the source host) to its latest version.

  2. QEMU Guest Agent is not running on the source VM: Make sure QEMU Guest Agent is installed and running on the source VM.

  3. QEMU Guest Agent on the source VM is out-of-date: Update QEMU Guest Agent on the source VM to its latest version.

  4. Volume Shadow Copy Service (VSS) is not running properly on the source VM: Check the Windows logs on the source VM for Volume Shadow Copy Service errors.